How do I connect +5V index pulse to UCBB?

This Section is for users to discuss hardware

Re: How do I connect +5V index pulse to UCBB?

Postby cncdrive » Sun Jun 28, 2020 3:59 pm

Sure, no problem. :)
cncdrive
Site Admin
 
Posts: 3404
Joined: Tue Aug 12, 2014 11:17 pm

Re: How do I connect +5V index pulse to UCBB?

Postby DavoH » Thu Jul 30, 2020 11:48 am

cncdrive wrote:So, your sensor output is push-pull (totem pole), but it has a 390 Ohm resistor in series and this is why it does not work with the UCBB inputs.

What you could do is you could place an external NPN transistor between the sensor and the UCBB input and then you could use higher Voltage too.
Connect the NPN transistor Base to your sensor's output, connect the transistor Emitter to 0Volts and connect the transistor Collector to Input- of the UCBB and connect a positive 12 to 24V Voltage to the UCBB input+.
Then your sensor output will drive the NPN transistor and when the transistor is on then the current will flow from the 12 to 24V through the UCBB optocoupler (input+ to input-) and then through the transistor Collector to Emitter.
One thing is that the transistor will invert your signal, but that is not a problem for an index signal.


I am going quietly insane trying to get this to work. I have tried three different 2N2222A transistors (connected as you said, using the 24V powering the UCBB) all with the same result, which is NO input seen by the UCCNC software or the input pin's LED. I am careful to observe anti-static procedures.
All that set-up does is drag the index signal voltage down from about 4.5V to around 1.5V.

However, I accidentally disconnected the 0V to the Emitter and was surprised to see the Input- pin LED activate and the software showed the correct spindle speed. The only connections I had were the index signal to the Base, and the Collector to the Input- pin. Plus of course I still had 24V connected to the Input+.
Even more surprising, by moving the index signal from the Base to the Emitter (with the Collector still connected to the Input-) I got the same result, the LED indicating and software reporting correct speed, still without a 0V connection.
In both of those cases the index signal did not drop and remained at a healthy 4.5V.

What is going on? It doesn't make sense.
Maybe I have a weird batch of 2N2222A transistors? Possibly labelled incorrectly.

Hopefully someone can tell me what's going on.

Thanks,
Davo.
DavoH
 
Posts: 16
Joined: Sat Dec 16, 2017 9:49 am

Previous

Return to Hardware

Who is online

Users browsing this forum: Majestic-12 [Bot] and 0 guests