Limited Feedrate 1.2112 after and during Probing

If you have a question about the software please ask it here.

Re: Limited Feedrate 1.2112 after and during Probing

Postby trendsetter » Mon Jan 13, 2020 10:19 pm

So, after 2h of testing debugging and modifying the Marcos I found the issue.

Totally cracy combination:
I use your Xbox plugin, Eric and I recently experimenting with an A-axis. I put the A Axis on the same joystick as the Z-axis. I activated to move 2 axis at once. The A axis is much slower but the plugin can overwrite the maximum speed of the A axis. When this happens the controller goes into this error mode with slow G0 motion. This is only limit in G90 mode in G91 the G0 speed is ok.
UCCNC then needs to be closed an need to be stay closed for ~30 seconds. Afterwards the controller recovers again.

Eric it would be good to have again the 0-100% speed settings of all axsis with the Joystick. This would prevent such a failure.
And thanks for helping!
BR
Michael
trendsetter
 
Posts: 32
Joined: Fri Nov 03, 2017 5:20 am

Re: Limited Feedrate 1.2112 after and during Probing

Postby eabrust » Tue Jan 14, 2020 2:26 am

Hi Michael,

It would figure it was the xbox plugin :oops: Thanks for your patience and noting the issue.


First question, which version of the XBox plugin were you using, and verify the movement problem caused by the joysticks? Was it the 'max velocity' setting for the stick in latest versions that caused a problem?

You'll have to explain a little more what it is you were setting up in the xbox control plugin, I didn't quite follow your description. Please clarify what you mean by this statement:
The A axis is much slower but the plugin can overwrite the maximum speed of the A axis.


A screenshot of your settings of the plugin may help me, been a long day (and a Monday no less....) :) Also, is A a rotary for your setup? I never put much thought into combining a rotary w/ linear axis on one stick. Feel free to post here, or post it in the xbox plugin thread.


I should be able to easily split up setting an independent max speed for each axis of both sticks, and from what I think I understand, that would fix this. Just not sure what in the background happened to confuse the controller and require a reboot.

regards,
Eric
CraftyCNC: Plugins for UCCNC (and other neat stuff): http://www.craftycnc.com/plugins-for-uccnc/
eabrust
 
Posts: 175
Joined: Fri Sep 16, 2016 2:32 am
Location: Near Shirland IL, USA

Re: Limited Feedrate 1.2112 after and during Probing

Postby trendsetter » Tue Jan 14, 2020 7:41 pm

Hi Eric,

Absolutely correct, the velocity setting is causing the problem. I had on the left stick Z Axis and A Axis. (Changed to B now, to avoide it.)
Xbox Plugin.JPG

Speed setting is 10000 and therefore the max speed of 50 rotations is easily reached. Then the controller comes into this error mode.
A-Axis.JPG

Frankly speaking, it would be good to handle each axis separte or using percentage values. The Speed limit is also 10000, I would be able to go to 14700. Would be also good to remove this limit.
Hope this helps.

BR
Michael
trendsetter
 
Posts: 32
Joined: Fri Nov 03, 2017 5:20 am

Re: Limited Feedrate 1.2112 after and during Probing

Postby eabrust » Wed Jan 15, 2020 2:52 am

Hi Michael,

Frankly speaking, it would be good to handle each axis separate or using percentage values. The Speed limit is also 10000, I would be able to go to 14700. Would be also good to remove this limit.


Man you metric guys and your complaining about needing lots of numbers to go fast :) Just kidding of course :lol: .

Thanks for your findings and suggestions, I 'think' I've addressed everything that was causing your issue, and made it a little more customizable too. Please take a look at the XBox thread http://www.forum.cncdrive.com/viewtopic.php?f=14&p=18652#p18652, and download the latest version I just put out.

As always, let me know if something seems wrong.

regards,
Eric
CraftyCNC: Plugins for UCCNC (and other neat stuff): http://www.craftycnc.com/plugins-for-uccnc/
eabrust
 
Posts: 175
Joined: Fri Sep 16, 2016 2:32 am
Location: Near Shirland IL, USA

Re: Limited Feedrate 1.2112 after and during Probing

Postby trendsetter » Thu Jan 16, 2020 5:34 pm

Hi Eric,
It works perfectly thanks!
Really great Job.
BR Michael
trendsetter
 
Posts: 32
Joined: Fri Nov 03, 2017 5:20 am

Previous

Return to Ask a question from support here

Who is online

Users browsing this forum: No registered users and 1 guest