Saving Settings window stuck1.2039

If you think you've found a bug post it here.

Re: Saving Settings window stuck1.2039

Postby ger21 » Wed Jun 14, 2017 12:34 am

paulcc wrote:Gerry, this change has not affected the pin/port issue we discussed. Note that the UCCNC standard screenset will accept the pin/port assignment inputs.


Not sure if it's related, but he's also having an issue of not being able to assign port 1 pin 10 to his X axis home switch. It works fine for me using h is profile.
Gerry
UCCNC 2017 Screenset - http://www.thecncwoodworker.com/2017.html
ger21
 
Posts: 734
Joined: Sat Sep 03, 2016 2:17 am

Re: Saving Settings window stuck1.2039

Postby cncdrive » Wed Jun 14, 2017 3:18 am

Paul,

Thanks.
I still don't see what could possibly cause this lockup of the app., but made some changes in the code to see if it is somekind of deadlock.
Please test this one and let me know if it still freezes with this exe and if you see any popup messages when Saving the settings.

I've uploaded the test exe file to the same link as previously.
The download link http://www.cncdrive.com/UCCNC/UCCNC.exe
Just replace the UCCNC.exe file in your UCCNC installation. Do not rename the file.
cncdrive
Site Admin
 
Posts: 1338
Joined: Tue Aug 12, 2014 11:17 pm

Re: Saving Settings window stuck1.2039

Postby paulcc » Wed Jun 14, 2017 2:55 pm

Just tried new version with same anomalous results - green popup and then stuck. I tried with standard and 2017 screenset, results are the same.
paulcc
 
Posts: 10
Joined: Tue Jun 13, 2017 12:35 am

Re: Saving Settings window stuck1.2039

Postby cncdrive » Wed Jun 14, 2017 11:01 pm

Hi Paul,

Thanks.
Hmmm, that is what I call strange, because what I did in the last version is that I moved that panel control with the label Show and Hide codes from the UI invoke function into an UI timer.
so in this last exe the panel is shown and hidden in exact syncron with the UI thread and so there should be no way for a deadlock. So, I'm yet stuck to give a reason why this still happening,
I mean I see no possible reason for this. I will make a final try to figure it it, will check everything again, but at the moment I'm out of ideas.
cncdrive
Site Admin
 
Posts: 1338
Joined: Tue Aug 12, 2014 11:17 pm

Re: Saving Settings window stuck1.2039

Postby paulcc » Thu Jun 15, 2017 12:33 am

Breakthrough! I left the program alone after invoking save settings and, coming back a few minutes later, saw that the save was completed and popup was gone. So, I invoked it again and timed the popup. It turns out that it is not hung permanently, it just takes 40 seconds to clear. (My lack of patience has been a complicating factor!) Note that if I change a setting, invoke save and quit the program within just a few seconds, upon restarting the program, the settings are indeed saved. Therefore, it seems that the actual saving part of the function is working well and that there is some other issue delaying completion.
paulcc
 
Posts: 10
Joined: Tue Jun 13, 2017 12:35 am

Re: Saving Settings window stuck1.2039

Postby cncdrive » Thu Jun 15, 2017 5:59 am

Hi Paul,

Thanks for the news. That makes sense, because if it was really not working I would not have more ideas. :)

If the saving process is that slow then I think it is probably because of an antivirus software or the Windows Defender is messing with the profile file, so it delays the process every time the UCCNC writes in a new key.
If you have an antivirus software installed then try to disable it temporarily to see if it makes the saving process faster.
Also check if your antivirus software has an exclusion list from check and add the UCCNC and it's folder.

Also check the Windows Defender and add an exclusion for it for the UCCNC.
To do that type Defender in the Search box in the Start menu in your Win7.
Then click the Windows Defender and on the Defender Windows click Tools and then Options and on the left you will see an Excluded files and folders menu item, select that and then add the UCCNC folder and UCCNC.exe file.
cncdrive
Site Admin
 
Posts: 1338
Joined: Tue Aug 12, 2014 11:17 pm

Re: Saving Settings window stuck1.2039

Postby paulcc » Thu Jun 15, 2017 2:07 pm

To avoid issues with antivirus programs and CNC, my controller is not connected to the internet and I have no antivirus program. Windows Defender has never been enabled, so this is not the issue. Yesterday, I did connect it to the internet to do a Windows update (which had no effect on the issue at hand).

This morning, I deleted my 2017 Screenset profile because it was having an issue accepting pin/port assignment for the A axis (very odd, only the home switch on the A axis, all others ok??). I configured the Default profile and confirmed it works and then tried to create a new 2017 profile. However, after entering the name of the profile I wish to create and invoking "Create New Profile" I get a popup that says "No profile name textfield is empty, no new profile was created"
paulcc
 
Posts: 10
Joined: Tue Jun 13, 2017 12:35 am

Re: Saving Settings window stuck1.2039

Postby ger21 » Thu Jun 15, 2017 2:38 pm

Hit the Enter key after typing the profile name.

And double check that Windows Defender is not running. It's enabled by default, so unless you disable it, it's probably running.
Gerry
UCCNC 2017 Screenset - http://www.thecncwoodworker.com/2017.html
ger21
 
Posts: 734
Joined: Sat Sep 03, 2016 2:17 am

Re: Saving Settings window stuck1.2039

Postby cncdrive » Thu Jun 15, 2017 2:46 pm

Windows Defender has never been enabled, so this is not the issue. Yesterday, I did connect it to the internet to do a Windows update (which had no effect on the issue at hand).


You do not have to enable it, it is enabled by default. So that you never enabled it does not mean it is not running. You have to disable it or add the UCCNC in the exclusions.

This morning, I deleted my 2017 Screenset profile because it was having an issue accepting pin/port assignment for the A axis (very odd, only the home switch on the A axis, all others ok??). I configured the Default profile and confirmed it works and then tried to create a new 2017 profile. However, after entering the name of the profile I wish to create and invoking "Create New Profile" I get a popup that says "No profile name textfield is empty, no new profile was created"


As Gerry said if typing in a new port or pin number or any other data then you have to press the Enter keyboard key to validate the input.
You can disable this behavior of the UCCNC on the Diagnostics/Appearance tab page and untick the Validate textfields with enter key only option and then Apply and/or Save the settings.
cncdrive
Site Admin
 
Posts: 1338
Joined: Tue Aug 12, 2014 11:17 pm

Re: Saving Settings window stuck1.2039

Postby paulcc » Thu Jun 15, 2017 5:11 pm

I actively disabled Windows Defender long ago and reconfirmed now. It has not been active during this entire process.

And yes, I got bitten again by the "Enter" requirement. Create profile works fine without pilot error! However, in the 2017 profile issue with the A axis, entering is not the issue. In this case, entering actually clears the text field!
paulcc
 
Posts: 10
Joined: Tue Jun 13, 2017 12:35 am

PreviousNext

Return to Report a bug

Who is online

Users browsing this forum: No registered users and 2 guests

cron