Page 1 of 1

HotKeys Glitch

PostPosted: Fri Jun 01, 2018 2:13 pm
by Vmax549
I found what appears to be a glitch in hotkeys.

IF I set up a hotkey say {F5} to trigger m20932 it works fine.

BUT IF I set up another hotkey {Alt_F5} to trigger button 6333 when I use that hotkey it runs BOTH {F5} and {Alt_F5} at the same time. Both functions activate.

(;-) TP

Re: HotKeys Glitch

PostPosted: Fri Jun 01, 2018 2:17 pm
by dezsoe
Yes, it's a known issue with the function keys. Any modifier keys (Alt, Ctrl, Shift, AltGr) works the same with them.

Re: HotKeys Glitch

PostPosted: Fri Jun 01, 2018 3:45 pm
by Vmax549
It is not just a function key problem it is ANY keyboard charector.

{B} and {Alt_B} Runs both functions
{B} and {Ctrl_B} Runs both functions

Are there any plans to fix it ??

(;-) TP

Re: HotKeys Glitch

PostPosted: Fri Jun 01, 2018 3:54 pm
by dezsoe
I've tried it now, but only the function keys have this problem. I didn't try B but O as I have Ctrl-O defined and it starts only with Ctrl.

I made one more test. If I define X to a function, it works also with Ctrl-X, Shift-X etc. If I define a function with Ctrl-X then it works only with Ctrl-X. So the problem is more complex. :( I put it on my list of issues.

Re: HotKeys Glitch

PostPosted: Sat Aug 11, 2018 3:08 pm
by Vmax549
Hi Dezoe, Did you ever come up with a solution to fix this problem using alt keys ??

(;-) TP

Re: HotKeys Glitch

PostPosted: Sat Aug 11, 2018 3:52 pm
by dezsoe
Hi Terry, No. But it's Bal√°zs who can repair it. Nowadays I use a touchscreen tablet without any keyboard. That's why I made the OSK plugin to work with MDI. :)

Re: HotKeys Glitch

PostPosted: Sun Aug 12, 2018 12:55 pm
by cncdrive
Yes, this is a to be fixed issue.