UCR201 USB wireless pendant

Post anything you want to discuss with others about the software.

Re: UCR201 USB wireless pendant

Postby PillyWilly » Wed Mar 13, 2019 11:35 am

cncdrive wrote:Hi Dan,

The Cultureinfo thing is for program threads. There can be 2 cases, we set it to EN/US or we forget to set it and then Windows uses the cultureinfo of that particular Windows installation.
When a macro thread is created then we set the cultureinfo to EN/US, so the macro always has the EN/US cultureinfo.

In plugins in the events/calls we also set the cultureinfo to EN/US when the thread is created and so the plugin writter does not have to set the cultureinfo.
I mean this is the plan how it should go, but a few times we forgot to set the cultureinfo for some events/calls and so then an issue could happen in the plugin if the programmer of the plugin did not take care to set the cultureinfo for that event for his code, if he coded things in the call which are cultureinfo dependent.
And in plugins the plugin writter can create their own threads which are independent of the UCCNC main code, so we can't set the cultureinfo for those externally created threads, for those the programmer of the plugin has to set the cultureinfo properly if it is required for his code. (The best if it is just set)

I have an idea though (and this question is to PillyWilly, because he can reproduce this issue), it is not about the cultureinfo, but to debug to see it closer where the problem lies.
My idea is that I will make a test UCCNC.exe in which I will code some Console writelines directly at the exec.Code calls to see what exactly texts does the Exec receives for execution from the machine.
Then PillyWilly could simply redirect that to the Console debugger to see the texts. And when the problem happens then he can upload a printscreen to let me see.
I would especially like to see what commands are sent to the executer, what commands, what coordinates etc. to understand the issue better.
So, the question to PillyWilly is if you will install this exe if I make one and if he will print some results for me? I mean I will only make this if he is willing to test it, because otherwise it would be useless to make anything like that, because the issue is unreproducable at us.


But offcause, anytime. I will be more than happy to help out.
Just send me the. exe and a description how to get the data to the Console.

Regards
Jan
PillyWilly
 
Posts: 71
Joined: Wed Oct 25, 2017 6:29 pm

Re: UCR201 USB wireless pendant

Postby ger21 » Thu Mar 14, 2019 2:14 am

I just realized that I had never updated the M6 macro to prevent possible exponents.
But I don't think anyone was having trouble with the M6???
I've attached an updated copy below, but am not able to test it.
Attachments
M6.txt
(14.79 KiB) Downloaded 85 times
Gerry
UCCNC 2017 Screenset - http://www.thecncwoodworker.com/2017.html
ger21
 
Posts: 1606
Joined: Sat Sep 03, 2016 2:17 am

Re: UCR201 USB wireless pendant

Postby Dan911 » Thu Mar 14, 2019 2:31 pm

Dan911 wrote:Hi Ger,

As Balaz explained here the same as he did in an older thread I understood any Cultural Info in a macro is handled within UCCNC (EN/USA), NOT the same for plugin though and needs to be addressed.
I know nothing of this issue other than what I read in this thread and only facts that seems clear is pendent/plugin works with no issues and screenset/macros been working flawless, put together there's a conflict. I posted what seemed to be obvious to me.

The explanation of the regions setting in UCR201 plugin sorta blows this guessing theory out the window....

One thing which can be a problem though is with math calculations when the calculated number comes out in exponent format, e.g. 1.2e-6.


I see Ger's macro limits to 2 decimal places which I would think should avoid this error, also if only happening when plugin is enabled than something is changing it's calculations?

Interested in seeing end result cause.


Obviously my typing is quicker than my thinking... This makes total sense as a probable cause, overlooked what plugin is actually doing. Writing to axis dro's macro is reading from.

Gerry, since this is only able to be resolved with a system that can reproduce the error and phillyWillie is willing to test why not make a edited macro with reformatting field before/after calculations?

Something like ""double Zmachine = Math.Round(AS3.Getfielddouble(20300), 4);" or at least a messageBox of calculated value to see if this error is there? From what I read this happens almost every time on second probe.
Dan911
 
Posts: 610
Joined: Mon Oct 31, 2016 1:22 am
Location: USA

Re: UCR201 USB wireless pendant

Postby ger21 » Thu Mar 14, 2019 2:58 pm

The issue is only when you send a number with an exponent to g-code, which I don't do. There are no issues with the actual calculation with exponents.

I can do it, but I may not be able to get to it for a week or so. Really really busy the next few days.

I'll add a message box after every calculation, to see if that tells you what's happening.
Gerry
UCCNC 2017 Screenset - http://www.thecncwoodworker.com/2017.html
ger21
 
Posts: 1606
Joined: Sat Sep 03, 2016 2:17 am

Re: UCR201 USB wireless pendant

Postby PillyWilly » Tue Mar 19, 2019 6:58 pm

Hi

Just an short update.

As I told you, I ordered a cheap Chinese cabeled Pendant. It arrieved today, and as you told me, the problem havent changed. It is the exact same issue, using the Plugin for the new Pendant, and disabeling the one for the UCR201.

So, any help you can give, or file you might want me to try out, please let me know, it is SO frustrating.
At least the probing works perfect when using the keyboard, so I can run my projects as planned.

Regards
Jan
PillyWilly
 
Posts: 71
Joined: Wed Oct 25, 2017 6:29 pm

Re: UCR201 USB wireless pendant

Postby dezsoe » Tue Mar 19, 2019 9:51 pm

Hi Jan,

What kind of pendant did you get and which plugin do you use with it? (Can you show a link to the pendant?)
dezsoe
 
Posts: 864
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: UCR201 USB wireless pendant

Postby PillyWilly » Wed Mar 20, 2019 9:32 pm

dezsoe wrote:Hi Jan,

What kind of pendant did you get and which plugin do you use with it? (Can you show a link to the pendant?)


Sure. I bought this one. https://www.ebay.co.uk/itm/HB04-USB-Wired-Handwheel-MPG-Pendant-Mach3-CNC-3-4-Axis-Milling-Router-System/123211554057?ssPageName=STRK%3AMEBIDX%3AIT&_trksid=p2057872.m2749.l2649

The pendant works just fine. But when enabeling the plugin that comes with UCCNC for the HB04 the probing stops working.

I bought it after seeing this video https://m.youtube.com/watch?v=q_a-pK698dk&t=228s

Regards
Jan
PillyWilly
 
Posts: 71
Joined: Wed Oct 25, 2017 6:29 pm

Re: UCR201 USB wireless pendant

Postby dezsoe » Thu Mar 21, 2019 9:09 am

Thanks! That's why I asked. The HB04, UCR200 and UCR201 plugins have the same problem with the probe. But I still could not reproduce it and that's why we cannot fix it. :( I downloaded the Danish Win10 and will install it to test if the problem is related to the language.
dezsoe
 
Posts: 864
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: UCR201 USB wireless pendant

Postby cncdrive » Thu Mar 21, 2019 9:33 am

Dezsoe, I think it would be helpful also if you could modify Gerry,'s probing macro and send it to PillyWilly.
Modify it with outputting all the exec.Code strings into a file or onto the Console and ask him to show the results.
Then we would see if it is an exponent number representation problem or if anything with those command strings.
cncdrive
Site Admin
 
Posts: 2937
Joined: Tue Aug 12, 2014 11:17 pm

Re: UCR201 USB wireless pendant

Postby dezsoe » Thu Mar 21, 2019 9:35 am

OK, thanks, good idea. :)
dezsoe
 
Posts: 864
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

PreviousNext

Return to General discussion about the UCCNC software

Who is online

Users browsing this forum: No registered users and 3 guests