Homing Backoff not working

Post anything you want to discuss with others about the software.

Homing Backoff not working

Postby rwb59 » Sun Jun 28, 2020 11:18 pm

I have been running the UCCNC homing sequence with NPN prox's for limit/home switches for quite some time. I recently changed the breakout board to a CNCDrive UCBB and the homing sequence now doesn't back off the limit/home proximity switches. I'm using the 2017 Screenset with UCCNC ver 1.2049. That hasn't changed. Only the UCBB has changed. Any idea what I could have done wrong?
rwb59
 
Posts: 2
Joined: Sun Jun 28, 2020 10:53 pm

Re: Homing Backoff not working

Postby cncdrive » Mon Jun 29, 2020 12:11 am

My first quess:
Your original breakout board probably used cheap slow optocouplers and the home switches does not switch clean, they switching on/off/on/off at the switching point.
The UCBB has fast optocouplers which can transmit such short pulse like signals also while cheap slow optocouplers will not switch those signals through, because they switching slower than how long the signal pulse is.
So, in this case this is a disadvantage of the fast optocouplers, but ofcourse fast optocouplers has the advantage of cleaner switching point and you can connect fast signals also e.g. encoders which would not work with slow optocouplers.

The solution for the problem is to use a newer version of the UCCNC.
Newer versions have 2 solutions:
1.) A backoff distance parameter which moves the axis away from the sensor, so it does not matters if there are spikes from the home sensor if you set the backoff distance far enough. Usually a very small distance does the job.(depends on the sensor/switch)
2.) Debounce filter which filters out the input signals. There is a separate debounce for homes and limits, you can set a few milliseconds, it will filter out those short spike signals.

My second thought:
Make sure that the home inputs polarity is set correctly. Go to the diagnostics and when the axes are off the home switches then verify that the Home LEDs are off, otherwise if they are on when the axes are on the home switch then you need to change the home input Active low sensor which reverses the signal active polarity. I thought about this as a possible problem because the signal polarity might be the opposite between your old BOB and the UCBB. So verify this.
cncdrive
Site Admin
 
Posts: 3449
Joined: Tue Aug 12, 2014 11:17 pm

Re: Homing Backoff not working

Postby rwb59 » Mon Jun 29, 2020 10:07 pm

A newer version of UCCNC did the trick. I appreciate your help!!
rwb59
 
Posts: 2
Joined: Sun Jun 28, 2020 10:53 pm


Return to General discussion about the UCCNC software

Who is online

Users browsing this forum: No registered users and 5 guests