UC300-5lpt / Mach3 / Input pin state problem

This Section is for users to discuss hardware

UC300-5lpt / Mach3 / Input pin state problem

Postby tswiss » Tue Mar 30, 2021 5:13 pm

Hi,

I'm updating from UC100 to UC300 (with ATC spindle upgrade), using Mach3 and G540.

UC300 is well connected and working, but I don't know how to use input pins outside LPT2. No matter what I do in "Mach3 / Ports and pins /Input" I cannot turn off any green light on Input Pin State screen LPT1, LP3, LPT4 or LPT5. I guess if I activate it and choose active low it should change appearance? And then give +5V to pin should light it up? Or would it be too simple? LPT2 works fine through G540. Outputs for relays work at LPT3.

Thanks for your help!
tswiss
 
Posts: 1
Joined: Tue Mar 30, 2021 5:02 pm

Re: UC300-5lpt / Mach3 / Input pin state problem

Postby cncdrive » Fri Apr 02, 2021 7:45 pm

The pin state green/grey indicates if the input pin is on high (5Volts) or low(0Volts) level.
If you change the active low of an input function will not change the virtual LED in the diagnostics, because changing that does not change the voltage level of the pin.
The virtual LED changes if you physically change the input pin voltage level.
Green indicates that the input is on high level. In the controller all inputs are on high level if nothing is connected to the input pin. (pullup resistor to 5Volts inside).
So, you can pull the input pin to ground (pins 18 to 25 are the ground pins) to change the input pin from green (high) to grey (low.
cncdrive
Site Admin
 
Posts: 3694
Joined: Tue Aug 12, 2014 11:17 pm


Return to Hardware

Who is online

Users browsing this forum: No registered users and 4 guests