MODBUSEZ Plugin

This is where you talk about Plugins. How they are made and how they work, show examples.

Re: MODBUSEZ Plugin

Postby dezsoe » Thu May 17, 2018 7:33 am

If only restarting Windows helps then maybe, something remains in memory when you exit UCCNC. Try the following: start UCCNC, test spindle, exit UCCNC, start task manager, try to find stuck UCCNC process by pressing U repeatedly until it goes around all processes starting with U. If you find UCCNC then there is something which prevents all threads to close. You can stop the process and try again. If it works then you found the problem. (In the past I had the same problem with a plugin development. :))
dezsoe
 
Posts: 594
Joined: Sun Mar 12, 2017 4:41 pm
Location: Csörög, Hungary

Re: MODBUSEZ Plugin

Postby Dan911 » Thu May 17, 2018 12:20 pm

Hmmm, I think it's very safe to assume it's not your RS485 connection. What seems to be happening is something is changing the way frequency is calculated, the only thing within UCCNC that can do this besides what I already posted to check is enabling pulleys. Also maybe a cultureinfo problem??

Knowing the different issue that's making you restart UCCNC can possibly help trouble shoot your problem since it's obviously related.

Dan
Dan911
 
Posts: 502
Joined: Mon Oct 31, 2016 1:22 am
Location: USA

Re: MODBUSEZ Plugin

Postby andrewwong2000 » Sun Nov 25, 2018 1:05 pm

I've just installed MODBUS EZ with my Powtran 9130 VFD, and can get the spindle to spin clockwise & ccw (following Dan's previous post on the subject).

But I can't seem to set the frequency ( using method one in the VFD manual).. it just seems to ignore any spindle setting from UCCNC.

As the start/stop works OK, I'm guessing it's probably some setting on the VFD.

Appreciate if anyone can suggest why the VFD accepts start/stop but not the freq command ?

Thanks,
Andrew
andrewwong2000
 
Posts: 2
Joined: Sun Nov 25, 2018 12:57 pm

Re: MODBUSEZ Plugin

Postby Dan911 » Sun Nov 25, 2018 5:05 pm

Dan911 wrote:Alex please look at snip I taken from your manual, your configured for second option using frequency address 1000 and your VFD is not going to accept the format ModbusSZ plugin is sending frequency.

You need to use first option using frequency address 0001. There's also a setting in your VFD for frequency resolution (F0.02) 1- 0.1hz and 2 - 0.01hz. If F0.02 is set to 1 than don't check box in ModbusEZ "Spindle Setup"

Use the new final V15 plugin I uploaded in previous post.

Dan

The attachment PT manual.JPG is no longer available


Your frequency address needs to be set to>>>>>>>>>>>>>>> 0001
Read the quote for frequency resolution, make sure that ModbusEZ corresponds with VFD settings.

Your VFD needs to be set to Keyboard sets frequency see snip of manual below.

Powertran 9100.JPG
Dan911
 
Posts: 502
Joined: Mon Oct 31, 2016 1:22 am
Location: USA

Re: MODBUSEZ Plugin

Postby andrewwong2000 » Wed Nov 28, 2018 2:40 pm

Hi Dan,

Thanks heaps.. turned out I had a conflicting function set up.

VFD & Plug in works great!

Cheers,

Andrew
andrewwong2000
 
Posts: 2
Joined: Sun Nov 25, 2018 12:57 pm

Previous

Return to Plugins

Who is online

Users browsing this forum: No registered users and 1 guest